Wednesday, October 30, 2013

Building a 477kHz receive loop





With the approach of the winter LF season it was time to look at building an LF receive antenna to put on the apartment balcony. My attention was drawn to the design by wa1zms A Simple Loop Antenna for 500 kHz. It looked straightforward to build. The half inch wood was available at the local hardware store. The hard question was how to cross the wood at the centre. Luckily Bob WA5YWC stepped in and milled the crossover portion to be a snug fit, solving that issue. Each arm had 8 holes (for the 8 turns of wire) spaced at 0.5". The two arms were secured with a brass screw to allow dismantling

I had found some 10/46 Litz wire on ebay. It soon became very apparent that this was too fragile to use as it snagged and broke with ease. A further internet search revealed a supply of the more robust 10/26 Litz wire from scotts electronic Parts It was not cheap but it would do the job. The wire was mounted on the frame easily and terminated with two brass nails. I measured the inducance and found it was 65uH, meaning around 1700pF would be needed to resonate the loop at around 475kHz. This value was soldered across the brass pins.


A visit to the local emporium produced all the components for the preamp including a box and stripboard. This was assembled and attached to the mast with adhesive backed velcro and a 9V battery attached. . I hooked it up to the ANAN-10 and took a listen around 475kHz.  but I noticed that the PowerSDR software was indicating an A/D overload. The preamp was acting as a wideband power oscillator! I re-examined the wiring finding a couple of extra short circuits which were fixed. Reconnecting it to the receiver I could hear the WG2XIQ on 475.7kHz and the antenna showed the expected very sharp nulls

131028 0152  25  -7  0.3   0.475663  WG2XIQ EM12 30
131028 0156  24  -8  0.5   0.475663  WG2XIQ EM12 30
131028 0200  23  -9 -2.0   0.475663  WG2XIQ EM12 30
131028 0208  10 -21 -1.4   0.475663  WG2XIQ EM12 30
131028 0212  10 -21 -0.3   0.475663  WG2XIQ EM12 30
131028 0216  11 -20 -0.2   0.475664  WG2XIQ EM12 30

Wednesday, October 2, 2013

Beaglebone Black Spectrum Analyser




I had seen Stephen Ongs youtube video and decided to give it a try. I followed the detailed instructions at  http://robotics.ong.id.au/2013/08/25/viewrf-rtl-sdr-spectrum-analyzer-for-bbb-software/ (remembering to include the "opkg install libusb-1.0-dev" mentioned in the comments) and it worked first time! I used a monitor not the LCD-7 Display ($150 if you can get them!)

I did not need to expand the file system to increase the available space to the full 8GB. When installed it only used 44% of the around 2GB available

The display (like the RTL-SDR dongle) has a bandwidth of ~2MHz but a 2GHz spectrum analyser for $65 one cannot complain

Tuesday, October 1, 2013

BeagleBone Black Ubuntu 13.04 with desktop... FAILURE!!

Flushed with success of getting Ubuntu 12.4 working with a Desktop I decided to see if Ubuntu 13.04 would work with a Desktop

I downloaded ubuntu-raring-13.04-armhf-3.8.13-bone20.img from http://circuitco.com/support/index.php?title=Ubuntu_On_BeagleBone_Black#Main_Process unzipped it and wrote the image to an 8GB microsd card using win32diskimager programme on my windows machine

The microsd booted and gave me the ubuntu 13.04 welcome and login prompt. which resulted in the Ubuntu command line prompt. I expanded the file system using the instructions at http://www.armhf.com/index.php/expanding-linux-partitions-part-2-of-2/ to maximise the space available for the desktop. another

sudo apt-get update
sudo apt-get install ubuntu-desktop

and off it went installing again.  Four hours later I came back and saw the install was finished and rebooted the BBB and up came the familiar Ubuntu desktop and login prompt. However the mouse cursor was violently twitching and the desktop background flickering. I typed in the password, moved the mouse and the BBB froze and all the blue LED stopped flashing. I powered off the BBB and repeated the process and it still twitched and froze when the mouse was moved. Think I will stick with 12.04 desktop!!