Saturday, March 29, 2014

Lake Whitney State Park

After leaving Belton, rather than rush straight home I decided to go via the Lake Whitney state park. On the way up I35, on the north side of Waco I found the Colin Street Bakery cafe (the factory is in Corsicana...off the beaten track), so It was time for coffee and cake for lunch
Continuing on in glorious sunshine (yes the promised heat did arrive) the park was reached at 1400.  Paying the $5 admission I first explored the (closed) launch ramp but the ground surrounding the car park was too rocky to get the antenna base in. I moved to the area near the swim zone (noone was swimming ) and managed to erect the PAC-12 antenna with 4 radials. Again starting on 10m the SWR was at 1.5:1.



The CQWW WPX SSB contest was in full flow, but 5W to an 8' vertical doesnt stand a chance amongst the big signals and intermods on the band. (eg VK4KW was 59+20 on the vertical but the most response I got during 20 mins of calling was "WW2?" twice!  I struggled to work 10 stations in EA, LU, OH, VE6, VE7, W6 and W7. I tried fitting the 15m and 20m coils but those bands were not much better So I decided to give in and go for a walk round the lake trail. It was very obvious the Lake water level was low:-


 Rather than returning directly up I35E I took highway 77 (which runs parallel to I35E)  which goes through Hillsboro TX, Paris, TX (home of the concrete igloos) and Waxahachie (which promised BBQ downtown but had ran out!) before eventually getting on I35E and making it home.

Belton Hamfest

I havent been to the Belton Hamfest for 5 years so It would be Interesting to see any changes. Despite threats of 81F temperatures on Saturday It was very cold at 0645 when I set off from the hotel,  I can assure you. The location has been spruced up since the last visit but the hamfest still takes place in and around the drive in "barn" (The other half was being used for dressage lessons!)
Escorted by Roger N5PGH we found some interesting items. He bought an IC215 for (the FM cousin of the IC202) for $50 and a TS120V VFO for $20. I bought 50' of RG58 (for a 1296 preamp power cable) for $3, a 5A RF ammeter for $1 3/6/10dB mini circuits 1.5GHz attenuators at $2 and a 28V 52A PSU for $60. I had an interesting conversation with its seller about the 12V Power One power supply also on his table which was a relative of the one I was experimenting with last weekend.
I was looking for a butterfly capacitor to make a remotely tunable version of the Alexloop. The 1st flea market spot, I found one. A bit dirty but .04" plate spacing 2 x 220pF. When I asked the price the owner presented it to me.  "enjoy"! Such friendship!

Friday, March 28, 2014

Mother Neff State Park



It was time, after a 5 year absence for a trip to the Belton hamfest.  Rather than rush down and back on Saturday I decided to go down on Friday and visit another state park on the way. I chose the Mother Neff State park SW of Waco and NW of Temple, which claims to be the first ever state park in Texas. The trip down I35 was uneventful,Lunch was taken In Waco then the route west was started. Immediately thunder, lightening and hail started! There was a lot of ground water when I got to the Park. Putting $2 admission in the honesty box I followed the ridge and found a parking spot. At which point the clouds went away and the sun came out. I planted the PAC-12 antenna with the 10m coil next to the car and called a few stations with the 5W CW from the KX3. I had 10 QSOs with JA, F, FG, DL, the only escapees were a DU and VK4. Being sprint a group of brilliant red red cardinals put on a display, as did the hawk that sat on the fence next to the antenna trying to work out what It was. Time for tourism so I went and looked at the cave on the way out. The warden, having observed my "paid" sticker was closing the access gate at 1630pm but she gave me the combination so I could escape at 1900, giving me just time for Dinner after the HPSDR Teamspeak session at 2000


Saturday, March 22, 2014

Sparkfun Bus Pirate issue found!

Spurred on by the LCD success,  the next Project was an FNP1500-48 1500W 48V power supply that I got off ebay to power my 700W HF amplifier. It was much smaller and lighter than my Lambda 48V 32A power supply. It was originally intended to be mounted in a chassis along with other identical modules with an LCD as a server power supply and therefore had an I2C Interface. This could be investigated with the Bus Pirate. I found the manual online for the power supply and also the IIC specification.
First a connector for the 20 pin connector on the supply was needed. This was constructed on a piece of stripboard with four 5 pin female 0.1" female connectors Gorilla glued in place. I connected leads to the SCL SDA and Gnd and powered up the power supply. Nothing, even after moving the recessed switch on the front panel from "0" to "1". Re reading the manual, more carefully Pin R1 and S5 have to be connected to activate the power supply. This worked and the power supply produced 49.8V output. Time to hook up the Bus Pirate

I had a Seed studio Bus Pirate Probe kit which breaks out the 10 pin connector to 10 mini hooks. Using the colour scheme of the bus pirate IIC,  v command.

1.(BR)  2.(RD)  3.(OR)  4.(YW)  5.(GN)  6.(BL)  7.(PU)  8.(GR)  9.(WT)  0.(Blk)
GND     3.3V    5.0V    ADC        VPU     AUX     SCL     SDA      -            -


 I hooked up the appropriate pins (1& 7&8) , with 10K pullup resistors I started bus pirate. This has a macro for searching for IIC addresses.  Ran the macro, found nothing. Did not see anything in or out on my $20 oscilloscope, so I started looking at voltages again. I noticed that 5V appeared between pins 0 and 9 on cable plugged into  the Sparkfun board. Was the connector on the Sparkfun board flipped?. I went to the web and looked at the board pictures

SEEDSTUDIO VERSION

SPARKFUN VERSION
Spot the difference? The seed studio board has the notch on the connector away from the edge of the PCB whereas the Sparkfun board has the notch on the PCB edge of the connector. This explains the problem. Luckily the plastic housing on the sparkfun board is not glued down, it lifts off and could be made to match the seedstudio unit.. Hooked up the power supply and ran the IIC scan and found the IIC addresses as listed  in the manual.

Bus Pirate v3.a
Firmware v6.1 r1676  Bootloader v4.4
DEVID:0x0447 REVID:0x3046 (24FJ64GA002 B8)
http://dangerousprototypes.com
HiZ>m                                         <change mode
1. HiZ
2. 1-WIRE
3. UART
4. I2C
5. SPI
6. 2WIRE
7. 3WIRE
8. LCD
x. exit(without change)

(1)>4
Set speed:
 1. ~5KHz
 2. ~50KHz
 3. ~100KHz
 4. ~400KHz

(1)>4
Ready
I2C>W
POWER SUPPLIES ON
I2C>P
Pull-up resistors ON
I2C>(1)
Searching I2C address space. Found devices at:
0xBE(0x5F W) 0xBF(0x5F R)

Perhaps the Sparkfun unit connector is deliberately missorientated so you cannot run their competitors accesories? We will see their response! (update: they claim they didn't and they didn't know of the issue, but posts on their web page for their buspirate raised the issue 3 years ago!)

Going back to the LCD Interface this no longer worked properly. So I connected it up with the original cable seedstudio supplied. It worked. Obviously it was the sparkfun connector orientation issue again

Antique radio Auction in Garland

Last week I was alerted by Roger from NTMS to an antique radio auction taking place in Garland, TX on Mar 22. The lots were pictured online and there were a couple of interesting items to me so it was worth a visit.

Its a good job Roger was there to explain how it worked, as I was confused by the schedule " local auction starts 9am internet auction 10am" Was there more than one auction?  So I averaged the two and got there with coffee at 0930. He pointed out I needed to register to bid which I did. A floating auction was underway of various boxes of (unlisted) stuff on the floor. The internet auction of the published lots started at 1000 prompt with lot #200. There were lots of valved HP test gear, motors, valved test gear and a couple of train sets, model sailing ships and a 1950s toaster. I had to wait a bit for my 1st lot of interest #268 which was a huge 1920s variometer but upon examination it had pieces missing so I didnt bid (went for $5) The main item of interest was a BC306A variometer at lot #306 (over an hours wait) I had the variometer part but wanted a complete unit with ceramic switch. I got this after some competitive bidding for $35 (plus buyers premium+sales tax =$39.78).



I hung around till lot 409 an HRO1-10A receiver but that had some very serious bidding ending up at $75

The most expensive radio item was an Atwater Kent model 10 breadboard radio.



Second was a Japanese WW2 TX/RX that went for $500

(The ship went for $200)

When I got home I opened up the ATU. Sturdily built inside!


Friday, March 21, 2014

Sparkfun Bus Pirate issues?

A few years ago I bought a Bus Pirate module from Seedstudio to investigate some I2C chips I had in the junkbox. Unfortunately I left it in England but last week I remembered a local emporium stocked them so I went to get one. Their version was by Sparkfun. At first glance it looked the same so I bought one and brought it home.


I found the LCD display that was giving me trouble. It was marked "emerging display EC16100TR" and was a 16x1 LCD. I still had the Seedstudio Bus Pirate LCD interface board so I connected that to the Bus Pirate. Nothing. Then I saw online that the LCD needed at least 5.4 code, mine had 5.1. So using these instructions I  upgraded it to 6.1 through the USB port. Still nothing, not even the power LED on the LCD board Lit up. As someone at BTRL once said "99% of all problems are power supply related" I started measuring voltages. I spotted that the voltage on a pin on the Bus Pirate did not correspond to those on the same pin on the LCD. I suspected the jumper cable was made badly, so I dug out another cable from my collection and the power LED lit up, progress! After some experimentation It turns out that even though It is a one line display the one line uses memory locations starting at 0 and 40 (a location usually only encountered in multiline displays) as can be demonstrated by the following Bus pirate command sequence (starting at bus pirate switch on):-

HiZ>i                                               <command
Bus Pirate v3.a                                 <response
Firmware v6.1 r1676  Bootloader v4.4
DEVID:0x0447 REVID:0x3046 (24FJ64GA002 B8)
http://dangerousprototypes.com
HiZ>m
1. HiZ
2. 1-WIRE
3. UART
4. I2C
5. SPI
6. 2WIRE
7. 3WIRE
8. LCD
x. exit(without change)

(1)>8
This mode requires an adapter
ReadyLCD>
(2)      
RESET        
Display lines:
 1. 1
 2. Multiple

(2)>1
INIT
LCD>(4) 0
CURSOR SET
LCD>"hello"
WRITE: "hello"
LCD>(4) 40
CURSOR SET
LCD>"radio"
WRITE: "radio"
LCD>

The result on the LCD is as follows:-